Как настроить IPTV на роутере Mikrotik

Поделиться

  1. Mikrotik IPTV – это устройство для подключения к телевещанию, которое требует дополнительных настроек. Перед этим сбрасывается ранее установленная конфигурация.
Настройка IPTV на Mikrotik

Сброс настроек роутера

Сбросить настройки роутера Микротик IPTV можно несколькими способами:

  • Через кнопку Reset на задней стороне устройства.
  • Нажатием на кнопку в специальном отверстии в плате роутера.
  • С помощью джампера.
mikrotik iptv

Первый вариант самый простой и доступен пользователям большинства роутеров.

Через кнопку Reset

Для сброса настроек до заводских параметров, например на моделях линейки Hap Lite, выполните инструкцию:

  1. Выключите блок питания.
  2. Найдите кнопку «Reset» на обратной стороне устройства, зажмите ее и не отпускайте.
  3. Запустите роутер, подключив блок питания.
  4. Дождитесь, пока не замигает лампа «ACT», затем сразу же отпустите кнопку «Reset».
mikrotik настройка iptv

Не дожидайтесь, пока лампочка перестанет мигать. Если жать слишком долго, то начнется процедура переустановки операционной системы.

Через отверстие в плате

Современные устройства с платой «RouterBOARD» имеют отверстие для доступа к кнопке сброса настроек, которая обозначена двумя полумесяцами.

Подробнее:

  1. Отключите блок питания.
  2. Переверните роутер для поиска отверстия. Если его нет, то придется открыть крышку устройства.
  3. Замкните контакты полумесяцев отверткой и не убирайте ее до момента сброса настроек.
  4. Подключите блок питания.
  5. Уберите отвертку от контактов, когда замигает лампа «ACT».
микротик настройка iptv

Подобный вариант восстановления заводских параметров сложнее предыдущего, поэтому используется только при отсутствии иных способов.

Сброс джампером

Инструкция для сброса параметров джамперов актуальна только для старых моделей роутеров.

Подробнее:

  1. Отключите блок питания.
  2. Найдите джампер с надписью «Soft Reset». Если его нет, то придется открыть крышку роутера.
  3. Зажмите две части джампера между собой отверткой или перемычкой. Не убирайте ее, пока не произойдет сброс.
  4. Подключите блок.
  5. Дождитесь сигнала о восстановлении заводских параметров и уберите перемычку.
микротик iptv

Если не убрать перемычку, то каждый новый запуск будет сопровождаться сбросом настроек.

Установка IPTV

Настройка телевещания на роутере Микротик начинается с установки новой операционной системы с подходящей версией.

Подробнее:

  1. Нужно скачать RouterOS и установить программу на компьютер. Это самая актуальная версия ОС для устройств Микротик.
  2. Откройте настройки устройства с помощью утилиты WinBox.
  3. Найдите кнопку «Files», перенесите туда файл из пакета с названием «multicast».
  4. Откройте раздел «System», найдите пункт «Reboot» или же введите в командную строку следующие символы: «system reboot». Это перезапустит роутер для того, чтобы изменения вступили в силу.
  5. Откройте пункт «System», в контекстном меню найдите раздел «Packages». Если в нем появился файл из пакета, то настройка мультикаста завершена.
mikrotik multicast iptv

Для просмотра телевидения этого мало, поэтому настройка Mikrotik IPTV продолжается.

Настройка IGMP Proxy

Настройка IGMP на Mikrotik IPTV связана с указанием данных подсетей провайдеров, которые нужны для приема сигнала. Если информации об этом у пользователя нет, то приходится перебирать «стандартные» варианты.

Подробнее:

  1. Через утилиту откройте раздел «Routing», затем перейдите в «IGMP Proxy».
  2. В открывшемся окне найдите строку «Interface», укажите в нем номер порта, куда подключен интернет.
  3. В разделе «Alternative Subnets» напишите номер подсети провайдеров, добавьте галочку в разделе «Upstream».
mikrotik iptv настройка мультикаст

В качестве «стандартных» вариантов можно использовать следующие:

  • 10.0.0.0/8;
  • 192.168.0.0/16;
  • 172.16.0.0/12.
  1. Остальные параметры оставьте по умолчанию, нажмите кнопку «ОК».
  2. Кликнете по изображению «+» для добавления портов ТВ.
  3. В поле «Interface» укажите порт роутера, который соединен с телевизором.
  4. Галочка не ставится, подсеть не прописывается. Нажмите кнопку «Ок».
  5. В окне «IGMP Proxy» найдите кнопку «Settings», нажмите на нее. Поставьте галочку в строке «Quick Leave», кликните «ОК».
настройка iptv mikrotik hap lite

Настройка прокси на этом завершена. При соблюдении всех указаний роутер будет принимать сигнал и передавать его на ТВ.

Настройка Firewall

На устройстве Микротик настройка IPTV осложняется встроенной защитой, которая может не пропустить сигнал телевещания. Поэтому дополнительно изменяются параметры фаервола.

Подробнее:

  • В главном меню утилиты найдите раздел «New Terminal».
  • Введите поочередно 3 строки программного кода, где вместо «*название порта входа*» прописывается порт, указанный в строке «Interface» на втором шаге предыдущей инструкции:

/ip firewall filter add action=accept chain=input comment="Allow IGMP" disabled=no in-interface=*название порта входа* protocol=igmp

/ip firewall filter add action=accept chain=input comment="IPTV UDP incoming" disabled=no dst-port=1234 in-interface=*название порта входа* protocol=udp

/ip firewall filter add action=accept chain=forward comment="IPTV UDP forwarding" disabled=no dst-port=1234 protocol=udp

  • После выполнения программного кода новые правила для фаервола добавятся в меню «Firewall», который находится на вкладке «IP».
  • Перенесите их в самый вверх, чтобы их приоритет стал выше запрещающих строк.

После этого можно просматривать телеканалы. Остальные настройки понадобятся тем, кто подключает роутер и телевизор по Wi-Fi.

mikrotik igmp iptv

Настройка Wi-Fi

Для настройки соединения Mikrotik Hap Lite IPTV и телевизора по Wi-Fi требуется выполнить инструкцию:

  1. В главном меню выберите раздел «Wireless».
  2. В открывшемся окне активируйте вкладку «Interface».
  3. Дважды кликните по имеющемуся подключению.
  4. На вкладке «Wireless» нажмите на кнопку «Advanced Mode».
  5. Установите режиме «Enable» в строке «WMM Support».
  6. Выберите «Full» в списке «Multicast Helper».
  7. Нажмите кнопку «ОК».
Настройка IPTV на Mikrotik

Если телевизор видит точку доступа роутера Mikrotik – настройка IPTV завершена. Остается подключиться к сети и просматривать телевещание местного провайдера.

Хочешь больше? Подпишись на наш Telegram.

Приложения к статье

Версия 2.1.0.20601
Версия 8.50 (61.05 МБ)
Версия 4.0 Build 9380 (10.46 МБ)
Читайте также

Никто не оставил комментарии или отзывы